实时浏览
在主视图页面查看已添加摄像机的实时视频——开始实时浏览、自动切换、PTZ 控制、窗口分割、手动录像与抓拍、即时回放、鱼眼、主从联动以及热成像实时浏览。
执行监控任务时,您可以在主视图页面查看已添加网络摄像机和视频编码器的实时视频。系统还支持一些基本操作,包括抓拍图片、手动录像、窗口分割、PTZ 控制等。
开始实时浏览
您可以开始单个摄像机或一个分组中所有摄像机的实时浏览。您也可以以自定义视图模式开始实时浏览。
开始单个摄像机的实时浏览
您可以只开始一个摄像机的实时浏览。
开始之前
实时浏览需要先定义一个摄像机分组。
操作步骤
-
打开主视图页面。
-
可选:点击实时浏览工具栏中的 ,为实时浏览选择窗口分割模式。
-
可选:点击实时浏览工具栏中的 ,设置显示比例、播放性能、图片保存路径等参数。
您也可以在系统配置中设置这些参数。详情请参阅系统配置。
-
执行以下操作之一,开始单个摄像机的实时浏览。
- 将分组中的某个摄像机从摄像机列表拖动到显示窗口,开始实时浏览。
- 选择一个显示窗口后,双击摄像机名称,开始实时浏览。
- 将光标移到摄像机名称上,选择一个显示窗口后,点击摄像机名称旁的 开始实时浏览。
如果设备支持码流加密,且其实时浏览的码流已加密,则需要输入码流密钥进行双重验证。
摄像机的实时视频将在所选窗口中开始播放。下一个窗口将被自动选中。
-
可选:将实时浏览中的摄像机视频拖动到另一个窗口,以更改实时浏览的显示窗口。
-
可选:将光标移到摄像机名称上,点击摄像机名称旁的 → Stream,根据实际需要切换码流类型。
您可以点击 All Stream Types,选择常用的码流类型显示在右键菜单中。
开始摄像机分组的实时浏览
您可以同步开始一个分组中所有摄像机的实时浏览。
开始之前
实时浏览需要先定义一个摄像机分组。
操作步骤
-
打开主视图页面。
-
可选:点击实时浏览工具栏中的 ,设置显示比例、播放性能、图片保存路径等参数。
您也可以在系统配置中设置这些参数。详情请参阅系统配置。
-
执行以下操作之一,开始一个分组中所有摄像机的实时浏览。
- 将摄像机分组从摄像机列表拖动到显示窗口,开始实时浏览。
- 双击分组名称,开始实时浏览。
- 将光标移到分组名称上,点击分组名称旁的 ,开始该分组中所有摄像机的实时浏览。
- 显示窗口数量会自适应分组中摄像机的数量。
- 如果设备支持码流加密,且其实时浏览的码流已加密,则需要输入码流密钥进行双重验证。
-
可选:将光标移到分组名称上,点击分组名称旁的 → Stream,根据实际需要为分组中的摄像机切换码流类型。
在切换到第六、第七、第八、第九和第十码流之前,您应在设备的网页配置页面中设置这些码流类型。详情请参阅该设备的用户手册。
添加自定义视图
视图是一种窗口分割,其中每个窗口都配置了相应的摄像机;视图模式使您能够将窗口分割以及摄像机与窗口的对应关系保存为收藏,以便日后快速访问相关摄像机。例如,您可以将办公室内的摄像机 1、摄像机 2 和摄像机 3 关联到显示窗口,并将其保存为名为"办公室"的视图。除了预定义的默认视图外,您还可以自定义视图以便进一步操作。
操作步骤
-
打开主视图页面。
-
将光标移到 View 面板中的 Custom View 上,点击 创建新视图。
-
为视图输入一个名称。
-
可选:点击实时浏览工具栏中的 ,为新视图设置窗口分割模式。
默认情况下,新视图为 4 窗口分割。
-
根据实际需要,在指定窗口中开始指定摄像机的实时浏览。
-
点击 直接保存视图。
-
可选:添加自定义视图后,执行以下操作。
- 编辑视图名称——将光标移到新视图上,点击 编辑视图名称。
- 删除视图——将光标移到新视图上,点击 删除该视图。
以自定义视图模式开始实时浏览
添加自定义视图后,您可以开始该自定义视图中摄像机的实时浏览。
开始之前
自定义一个包含窗口分割、摄像机以及摄像机与窗口对应关系等信息的视图。详情请参阅添加自定义视图。
操作步骤
-
打开主视图页面。
-
可选:点击实时浏览工具栏中的 ,设置显示比例、播放性能、图片保存路径等参数。
您也可以在系统配置中设置这些参数。详情请参阅系统配置。
-
点击 展开 View 面板中的自定义视图列表。
-
点击某个自定义视图开始实时浏览。所选视图中已添加摄像机的视频将会显示。
-
可选:以自定义视图模式开始实时浏览后,执行以下一项或多项操作。
- 开始即时回放——将光标移到新视图上,点击 开始该视图中摄像机的即时回放。详情请参阅即时回放。
- 开始所有自定义视图的自动切换——将光标移到 Custom View 上,点击 开始自动切换自定义视图列表中的所有视图。详情请参阅实时浏览中的自动切换。
实时浏览中的自动切换
您可以依次显示摄像机的实时视频或显示各个自定义视图,这称为"自动切换"。
在实时浏览中自动切换时,提供三种模式:
- 自动切换默认视图中的所有摄像机
- 自动切换一个分组中的摄像机
- 自动切换自定义视图
自动切换所有摄像机
摄像机列表中所有摄像机的视频可以自适应模式自动切换。如果您开始所有摄像机的自动切换,则可以快速显示所有摄像机的实时浏览,这是一种高效的实时浏览方式。自动切换按可配置的间隔进行。您也可以在自动切换窗口上切换到回放并执行其他操作。
操作步骤
-
打开主视图页面。
-
点击左侧面板中的 Auto-Switch → Multi-Window Auto-Switch。
-
将光标悬停在 Auto-Switch All Cameras 上,然后点击 。摄像机列表中的所有摄像机将以自适应模式开始自动切换。
-
可选:点击页面底部的 20 Seconds 更改自动切换间隔。
示例
如果您将间隔设为 10 秒,则每个摄像机的画面将显示 10 秒,然后切换到下一个摄像机。
自动切换一个分组中的摄像机
同一分组中摄像机的视频码流可以在所选显示窗口中自动切换。例如,如果您开始一个包含 5 个摄像机的分组的自动切换,则这 5 个摄像机的实时浏览将按可配置的间隔依次显示。您也可以在显示窗口上切换到回放并执行其他操作。
操作步骤
-
打开主视图页面。
-
点击左侧面板中的 Auto-Switch → Single Window Auto-Switch 显示分组。
-
在右侧面板上选择一个显示窗口。
-
将光标悬停在某个分组名称上,点击 。所选分组中的摄像机将在显示窗口中开始自动切换。
自动切换开始后,默认关闭音频。
-
可选:点击页面底部的 20 Seconds 更改自动切换间隔。
示例
如果您将间隔设为 10 秒,则每个摄像机的画面将显示 10 秒,然后切换到下一个摄像机。
自动切换自定义视图
视图是一种窗口分割,其中每个窗口都关联了资源通道(例如摄像机和出入口)。视图模式使您能够将窗口分割以及摄像机与窗口的对应关系保存为收藏,以便日后快速访问这些通道。如果您事先保存了一个包含某楼层所有摄像机的视图,则只需一站式操作即可依次查看该楼层所有摄像机的实时浏览。这样,您就无需每次登录时都在摄像机列表中查找这些摄像机。自动切换按可手动配置的间隔进行。
开始之前
添加自定义视图。详情请参阅添加自定义视图。
操作步骤
-
打开主视图页面。
-
点击左侧面板中的 Resource → Multi-Window Auto-Switch。
-
将光标悬停在 Auto-Switch All Views 上,点击 。所有自定义视图将开始自动切换。
-
可选:点击页面底部的 20 Seconds 更改自动切换间隔。
示例
如果您将间隔设为 10 秒,则每个摄像机的画面将显示 10 秒,然后切换到下一个摄像机。
PTZ 控制
软件为具有云台/俯仰/变焦功能的摄像机提供 PTZ 控制。在 PTZ 控制过程中,您可以设置预置点、巡航和轨迹,还可以打开一个新窗口来控制 PTZ。
Cloud P2P 设备仅支持向上、下、左、右方向的 PTZ 移动。
进入主视图模块,选择 PTZ Control 打开 PTZ 控制面板。PTZ 控制面板上提供以下图标。
表 6-1 PTZ 控制面板上的图标
| 名称 | 说明 |
|---|---|
| Direction Buttons | 点击或按住鼠标左键转动 PTZ。点击可水平连续转动 PTZ;再次点击可停止转动。 |
| Speed Control | 拖动滑块调整 PTZ 移动速度。 |
| Zoom in/out | 放大可查看近处图像细节;缩小可查看全景图像。 |
| Focus +/- | 点击 Focus + 使焦点前移,点击 Focus - 使焦点后移。 |
| Iris +/- | 用于调整图像的亮度。光圈越大,进光量越多,图像越亮。 |
| 3D Positioning | 用鼠标左键点击视频图像中所需位置,并向右下方向拖动一个矩形区域,则球机系统会将该位置移到中心并放大该矩形区域。用鼠标左键向左上方向拖动一个矩形区域,可将该位置移到中心并缩小该矩形区域。 |
| Auxiliary Focus | 点击可自动对焦。 |
| Lens Initialization | 初始化镜头并重新对焦,以获得清晰的图像。 |
| Light | 点击可补光。 说明:此功能需设备支持。 |
| Wiper | 使用雨刷清除摄像机镜头上的灰尘。 |
| Manual Tracking | 对于具有自动跟踪功能的快球,为其启用自动跟踪(通过右键菜单),点击该图标后,通过点击视频可手动跟踪目标。 |
| Menu | 对于模拟快球,点击该图标可显示其本地菜单。有关菜单的详细操作,请参阅快球的用户手册。 |
| One-Touch Patrol | 对于具有一键巡航功能的快球,点击该图标后,在一段时间无操作(停留时间)后,快球将依次从预定义的预置点 No.1 巡航至预置点 No.32。有关设置停留时间的说明,请参阅快球的用户手册。 |
| One-Touch Park | 对于具有一键停留功能的快球,点击该图标后,快球会将当前视图保存到预置点 No.32。在一段时间无操作(停留时间)后,设备将自动停留在预置点 No.32。有关设置停留时间的说明,请参阅快球的用户手册。 |
| Enable Manual De-Icing Heater | 启用此功能,以确保摄像机在 0℃ 以下环境中的性能。 |
| Manual Face Capture | 点击此按钮,按住鼠标左键在图像中框选一张人脸进行抓拍。图片将上传到服务器供查看。 |
| Synchronize FOV | 用于热成像摄像机。点击可将光学通道的视场与热成像通道的视场同步。 |
| Regional Exposure | 用于快球,点击该图标并在图像上绘制一个矩形,以优化该区域的曝光效果。 |
| Regional Focus | 用于快球,点击该图标并在图像上绘制一个矩形,以优化该区域的对焦效果。 |
配置预置点
预置点是一个预定义的图像位置,包含云台、俯仰、对焦及其他参数信息。设置预置点后,您可以通过调用预置点快速定位到所需的摄像机位置。
操作步骤
- 打开主视图页面并开始 PTZ 摄像机的实时浏览。
- 点击左侧的 PTZ Control 展开 PTZ 控制面板。
- 展开页面左下角的 PTZ 控制面板。
- 从主视图窗口中选择一个 PTZ 窗口。
- 可选:在 PTZ 控制面板上,点击预置点名称(例如 Preset 1)编辑预置点名称。
- 在 PTZ 控制面板上,点击 PTZ 控制面板上的方向按钮和功能按钮,将场景调整到您想标记为预置点的位置。
- 点击 保存预置点设置。
- 可选:设置预置点后,执行以下一项或多项操作。
- 调用预置点——选择预置点并点击 调用该预置点。您也可以按键盘上的数字键(例如 4)调用预置点 1 至 9,并按键盘上的 [、数字键(例如 124)和 ] 调用其他预置点。
- 编辑预置点——调整 PTZ 摄像机的方向、位置和视图,然后点击 再次保存预置点。旧的预置点设置将被替换。
- 删除预置点——从列表中选择已配置的预置点,点击 删除它。
配置巡航
巡航是由一组用户自定义预置点指定的扫描轨迹,两个预置点之间的扫描速度和在预置点的停留时间均可分别编程设置。
开始之前
为一个 PTZ 摄像机添加两个或更多预置点。
操作步骤
对于 Cloud P2P 设备,不支持巡航。
- 打开主视图页面并开始 PTZ 摄像机的实时浏览。
- 点击左侧的 PTZ Control 展开 PTZ 控制面板。
- 点击 选项卡进入 PTZ 巡航配置面板。
- 从下拉列表中选择一个路径号。
- 点击 打开添加巡航点对话框。
- 在对话框中从下拉列表选择一个预置点,并为该预置点设置停留时间和巡航速度。
- 点击 OK。
- 重复步骤 5、6 和 7,向巡航中添加其他预置点。
- 可选:设置巡航后,执行以下一项或多项操作。
- 调用巡航——点击 调用巡航。
- 停止调用巡航——点击 停止调用巡航。
- 编辑巡航中的预置点——选择巡航路径中的某个预置点,点击 编辑该预置点。
- 从巡航中移除预置点——选择巡航路径中的某个预置点,点击 从巡航中移除该预置点。
配置轨迹
轨迹是一段被记忆并重复执行的云台、俯仰、变焦和预置点功能序列。
操作步骤
对于 Cloud P2P 设备,不支持轨迹。
- 打开主视图页面并开始 PTZ 摄像机的实时浏览。
- 点击左侧的 PTZ Control 展开 PTZ 控制面板。
- 点击 选项卡进入 PTZ 轨迹配置面板。
- 点击 开始录制此轨迹路径。
- 使用方向按钮控制 PTZ 移动。
- 点击 停止录制并保存录制的轨迹。
- 可选:设置轨迹后,执行以下一项或多项操作。
- 调用轨迹——点击 调用轨迹。
- 停止调用轨迹——点击 停止调用轨迹。
- 删除轨迹——选择一个轨迹,点击 删除该轨迹。
- 删除所有轨迹——点击 删除所有轨迹。
自定义窗口分割
客户端软件提供多种预定义的窗口分割。您也可以根据需要自定义窗口分割。
操作步骤
最多可自定义 5 种窗口分割。
-
打开主视图或远程回放页面。
-
点击实时浏览或回放工具栏上的 打开窗口分割面板。
-
点击 Add 打开添加自定义窗口分割对话框。
-
在 Dimension 字段中输入水平和垂直方向的窗口数,然后按键盘上的 Enter 键。
对于远程回放,最多可同时播放 16 个窗口,因此超过 16 个窗口的自定义窗口分割无效。
-
可选:拖动鼠标选择相邻的窗口,点击 Joint 将它们合并为一个整体窗口。
-
可选:选择合并的窗口,点击 Restore 取消合并。
-
点击 Save。
-
可选:点击某个分割模式或将其拖动到显示窗口,以应用该模式进行显示。
-
可选:编辑自定义窗口分割模式。
- 点击实时浏览或回放工具栏上的 打开窗口分割面板。
- 点击 Edit 打开添加自定义窗口分割。
- 选择一个自定义分割模式,执行重命名、设置尺寸、合并/取消合并窗口等操作。
手动录像和抓拍
在实时浏览期间,您可以手动录像和抓拍图片,然后在本地 PC 中查看录制的视频文件和抓拍的图片。
手动录像
手动录像功能允许您在主视图页面手动录制实时视频,并将视频文件存储在本地 PC 上。
操作步骤
在实时浏览期间,Cloud P2P 设备不支持手动录像。
-
打开主视图页面。
-
开始实时浏览。
-
执行以下操作之一,开始手动录像。
- 将光标移到实时浏览的显示窗口上以显示工具栏,点击工具栏上的 。
- 右键点击显示窗口,在右键菜单中点击 Start Recording。
图标 将变为 。显示窗口的右上角将出现一个指示符。
-
点击 停止手动录像。录制的视频文件会自动保存到本地 PC,桌面右下角会出现一个带有保存路径信息的小窗口。
录制视频文件的保存路径可在系统配置页面设置。详情请参阅设置文件保存路径。
查看本地视频
您可以查看存储在本地 PC 中的录制视频文件。
开始之前
录制实时视频。
操作步骤
- 点击右上角的 → File → Open Video File 打开视频文件页面。
- 从摄像机分组列表中选择要搜索录制视频文件的摄像机。
- 在左下角指定搜索的开始时间和结束时间。
- 点击 Search。在开始时间和结束时间之间录制的视频文件将以缩略图形式显示在页面上。
- 可选:搜索后,执行以下一项或多项操作。
- 删除视频文件——选择视频文件,点击 Delete 删除该视频文件。
- 发送邮件——选择视频文件,点击 Email 发送一封带有所选视频文件附件的邮件通知。
- 说明:要发送邮件通知,需要先配置邮件设置才能继续。详情请参阅设置邮件参数。
- 保存本地视频——选择视频文件,点击 Save as 保存该视频文件的新副本。
- 回放——双击视频文件开始本地回放。
抓拍图片
您可以在实时浏览期间抓拍图片。当您需要在实时浏览期间抓拍图片时,请执行此任务。
操作步骤
-
打开主视图页面并开始某个摄像机的实时浏览。
-
执行以下操作之一,抓拍图片。
- 将光标移到实时浏览的显示窗口上以显示工具栏,点击工具栏上的 。
- 右键点击显示窗口,在右键菜单中点击 Capture。
抓拍的图片会自动保存到本地 PC,桌面右下角会出现一个带有图片预览和保存路径信息的小窗口。
抓拍图片的保存路径可在系统配置页面设置。详情请参阅设置文件保存路径。
查看抓拍的图片
在实时浏览中抓拍的图片存储在运行软件的 PC 上。如有需要,您可以查看抓拍的图片。
开始之前
在实时浏览中抓拍图片。
操作步骤
- 点击右上角的 → File → Open Captured Picture 打开抓拍图片页面。
- 从摄像机分组列表中选择要搜索抓拍图片的摄像机。
- 在左下角指定搜索的开始时间和结束时间。
- 点击 Search。在开始时间和结束时间之间抓拍的图片将以缩略图形式显示在页面上。
- 可选:搜索后,执行以下一项或多项操作。
- 放大图片——双击图片缩略图将其放大,以获得更好的查看效果。
- 打印图片——选择抓拍的图片,点击 Print 打印所选图片。
- 删除图片——选择抓拍的图片,点击 Delete 删除所选图片。
- 发送邮件——选择抓拍的图片,点击 Email 发送一封带有所选图片附件的邮件通知。
- 保存图片——选择抓拍的图片,点击 Save as 保存所选图片的新副本。
即时回放
即时回放显示一段引人注意或乍看不清晰的视频。这样,如有需要,您可以在主视图页面即时播放视频文件并立即回看。
开始之前
录制视频文件并将其存储在存储设备上,例如 DVR、NVR、网络摄像机等设备上的 SD/SDHC 卡和 HDD,或存储服务器上。
操作步骤
-
打开主视图页面并开始实时浏览。
-
执行以下操作之一,显示即时回放的预放时长列表。
- 将光标移到显示窗口上以显示工具栏,点击 。
- 右键点击显示窗口,在右键菜单中选择 Switch to Instant Playback。
- 将光标移到 View 面板上的默认视图或自定义视图节点上,点击 。
将显示一个包含 30s、1 分钟、3 分钟、5 分钟、8 分钟和 10 分钟预放时长的列表。
-
从出现的列表中选择一个时间段,开始即时回放。
示例
如果您选择 3 分钟,且实时浏览的当前时间为 09:30:00,则即时回放将从 09:27:00 开始。
在即时回放期间,显示窗口的右上角将出现一个指示符。
-
可选:再次点击 停止即时回放并返回实时浏览。
鱼眼摄像机的实时浏览
对于鱼眼摄像机,您可以以鱼眼模式开始实时浏览、设置预置点和巡航,并执行 PTZ 控制。
以鱼眼模式进行实时浏览
在鱼眼摄像机的实时浏览过程中,将显示整个广角畸变视图。但您可能难以查看某些细节。为解决此问题,您可以以鱼眼展开模式播放实时视频。鱼眼展开可以以多种模式展开图像:180° 全景、360° 全景、PTZ、半球等,以便您清晰地查看图像。
操作步骤
- 打开主视图页面并开始鱼眼摄像机的实时浏览。
- 进入鱼眼展开模式。
- 右键点击视频并选择 Fisheye Expansion。
- 点击工具栏中的 。有关设置工具栏的详情,请参阅设置工具栏显示的图标。 将变为激活状态。
- 点击显示窗口左下角的 打开安装方式与展开模式选择面板。
- 根据鱼眼摄像机的实际安装位置选择其安装方式。
- 根据需要为实时浏览选择展开模式。
-
Fisheye——在鱼眼视图模式下,显示摄像机的整个广角视图。此视图模式之所以称为鱼眼,是因为它近似于鱼凸出眼睛的视觉。镜头会产生大面积区域的曲线图像,同时使图像中物体的透视和角度发生畸变。
-
Panorama——在全景视图模式下,通过某些校准方法将畸变的鱼眼图像转换为正常透视图像。
-
PTZ——PTZ 视图是鱼眼视图或全景视图中某个定义区域的特写视图,它支持电子 PTZ 功能,也称为 e-PTZ。
每个 PTZ 视图都会在鱼眼视图和全景视图上用一个特定的导航框标记。您可以在鱼眼视图或全景视图上拖动导航框来调整 PTZ 视图,或拖动 PTZ 视图将视角调整到所需角度。
-
Half Sphere——通过半球模式,您可以拖动图像并以直径为中心旋转它,从而将视角调整到所需角度。
-
AR Half Sphere——AR 半球模式将远近图像叠加,以便您能以广角查看立体图像。
-
- 可选:以鱼眼模式开始实时浏览后,执行以下一项或多项操作。
- 抓拍——右键点击窗口并选择 Capture,在实时浏览过程中抓拍图片。
- 进入全屏——右键点击正在播放的窗口,将所选窗口切换为全屏模式。
鱼眼模式下的 PTZ 控制
在鱼眼模式下,您可以控制 PTZ 来调整 PTZ 窗口。
PTZ 面板因设备不同而异。
PTZ 控制面板上提供以下功能。
- 选择一个 PTZ 窗口,点击方向按钮调整视角。或在鱼眼或全景窗口中拖动编号标签来更改 PTZ 窗口的视角。
- 选择一个 PTZ 窗口,点击 开始自动扫描(摄像机沿水平方向旋转),再次点击可停止自动扫描。
- 拖动速度条上的滑块调整 PTZ 移动速度。
- 点击 / ,或滚动鼠标滚轮放大或缩小所选的 PTZ 窗口。
配置预置点
在鱼眼模式下,您可以配置预置点,预置点是用户自定义的监控位置/点,只需调用预置点号即可将监控场景切换到定义的位置。
操作步骤
只有特定的鱼眼摄像机支持配置预置点,在鱼眼模式下最多可配置 256 个预置点。
- 打开主视图页面并开始鱼眼摄像机的实时浏览。
- 右键点击视频并选择 Fisheye Expansion 进入鱼眼展开窗口。
- 展开页面左下角的 PTZ 控制面板。
- 从主视图窗口中选择一个 PTZ 窗口。
- 可选:在 PTZ 控制面板上,点击预置点名称(例如 Preset 1)编辑预置点名称。
- 在 PTZ 控制面板上,点击 PTZ 控制面板上的方向按钮和功能按钮,将场景调整到您想标记为预置点的位置。
- 点击 保存预置点设置。
- 可选:设置预置点后,执行以下一项或多项操作。
- 调用预置点——选择预置点并点击 调用该预置点。您也可以按键盘上的数字键(例如 4)调用预置点 1 至 9,并按键盘上的 [、数字键(例如 124)和 ] 调用其他预置点。
- 编辑预置点——调整 PTZ 摄像机的方向、位置和视图,然后点击 再次保存预置点。旧的预置点设置将被替换。
- 删除预置点——从列表中选择已配置的预置点,点击 删除它。
配置巡航
在鱼眼模式下,您可以配置巡航,巡航是由一组用户自定义预置点指定的扫描轨迹,两个预置点之间的扫描速度和在预置点的停留时间均可分别编程设置。
开始之前
配置两个或更多预置点。
操作步骤
只有特定的鱼眼摄像机支持配置巡航,在鱼眼模式下最多可配置 32 条巡航。
- 打开主视图页面并开始鱼眼摄像机的实时浏览。
- 右键点击视频并选择 Fisheye Expansion 进入鱼眼展开窗口。
- 点击 选项卡进入巡航配置面板。
- 从下拉列表中选择一个路径号。
- 点击 打开添加巡航点窗口。
- 点击 OK。
- 重复步骤 5、6 和 7,向巡航中添加其他预置点。
- 可选:配置巡航后,执行以下一项或多项操作。
- 编辑巡航中的预置点——选择巡航路径中的某个预置点,点击 编辑该预置点。
- 从巡航中移除预置点——选择巡航路径中的某个预置点,点击 从巡航中移除该预置点。
- 调用巡航——点击 调用巡航。
- 停止调用巡航——点击 停止调用巡航。
执行主从联动
支持主从跟踪功能的枪型或筒型摄像机可以根据您的需求定位或跟踪目标。
- 此功能仅由特定的枪型或筒型摄像机支持。
- 需要在枪型或筒型摄像机附近安装一台具有自动跟踪功能的快球。
配置主从跟踪规则
在实时浏览期间执行主从跟踪之前,您应为枪型或筒型摄像机配置主从跟踪规则,包括设置 VCA 检测规则、关联快球以及校准摄像机和快球。
设置入侵检测规则
您应为筒型或枪型摄像机设置 VCA 检测规则,当 VCA 事件被触发时,客户端可触发快球跟踪目标。这里以入侵检测为例。
操作步骤
- 打开设备管理页面并选择一台枪型或筒型摄像机。
- 点击 → Advanced Configuration → VCA Config → Rule → Rule Settings 进入规则设置页面。
- 在规则列表面板中点击 Add 添加一条规则。
- 选择 Intrusion 作为事件类型。
- 点击 在实时视频上绘制一个检测区域。
- 点击 Save。
关联快球
为枪型或筒型摄像机配置主从跟踪时,您可以将摄像机关联到一台快球,并为快球设置用于跟踪的 PTZ 位置。执行此任务,将枪型或筒型摄像机关联到一台快球以进行主从跟踪。
操作步骤
- 打开设备管理页面并选择一台枪型或筒型摄像机。
- 点击 → Advanced Configuration → Master-Slave Tracking 进入主从跟踪设置页面。
- 点击显示窗口上的 Login 打开快球登录窗口。
- 输入快球的 IP 地址、端口号、用户名和密码。
- 点击 Login 登录快球。
- 点击 PTZ 并使用方向箭头将快球调整到水平位置。
后续操作
校准枪型或筒型摄像机及关联的快球,详情请参阅自动校准摄像机和快球或手动校准摄像机和快球。
自动校准摄像机和快球
设置筒型或枪型摄像机的主从跟踪规则时,您应校准摄像机和快球。提供自动和手动两种校准模式,这里介绍自动校准。
开始之前
将摄像机关联到一台快球,详情请参阅关联快球。
操作步骤
- 打开设备管理页面并选择一台枪型或筒型摄像机。
- 点击 → Advanced Configuration → Master-Slave Tracking 进入主从跟踪设置页面。
- 在校准面板的右下角选择校准模式为 Auto Calibrating。
- 移动并放大/缩小快球的视图,确保快球和摄像机的实时浏览基本一致。
- 点击 Save。
手动校准摄像机和快球
设置筒型或枪型摄像机的主从跟踪规则时,您应校准摄像机和快球。提供自动和手动两种校准模式,这里介绍手动校准。
开始之前
将摄像机关联到一台快球。详情请参阅关联快球。
操作步骤
- 打开设备管理页面并选择一台枪型或筒型摄像机。
- 点击 → Advanced Configuration → Master-Slave Tracking 进入主从跟踪设置页面。
- 在校准面板的右下角选择校准模式为 Manual Calibrating。
- 从列表中选择站点 No.1 并点击 。实时浏览页面中央将出现一个蓝色十字,所选站点的数字变焦视图将出现在右侧。
- 重复步骤 4 添加其他手动校准站点。
- 在实时浏览页面中均匀调整四个校准站点之间的距离。
- 选择校准站点 No.1。站点 No.1 的数字变焦视图将出现在右侧。
- 移动并放大或缩小快球的视图,确保快球的实时浏览与所选站点的数字变焦视图基本一致。
- 点击 保存当前站点位置信息。
- 重复步骤 7、8 和 9,设置其他站点的位置。
- 点击 Save。
启用主从跟踪
在实时浏览期间,您可以启用主从跟踪,用快球定位或跟踪出现在筒型或枪型摄像机视图中的目标。
开始之前
为枪型或筒型摄像机配置主从跟踪规则。当您需要为枪型或筒型摄像机启用主从跟踪时,请执行此任务。
操作步骤
- 进入主视图页面并开始枪型或筒型摄像机的实时浏览。
- 右键点击实时浏览窗口并点击 Enable Master-Slave Tracking。当已配置的 VCA 规则被目标触发时,关联的快球将执行自动主从跟踪,目标框将从绿色变为红色。
热成像摄像机的实时浏览
对于热成像摄像机,您可以在实时浏览期间查看火源信息和温度。您还可以手动测温,在实时浏览图像中获取温度信息。
在实时浏览期间查看火源信息
在实时浏览期间,您可以查看检测到的火源信息。
开始之前
为热成像设备配置报警规则,详情请参阅该设备的用户手册。当您需要在实时浏览期间查看火源信息时,请执行此任务。
操作步骤
-
进入主视图页面并开始热成像摄像机的实时浏览。
有关开始和停止实时浏览,请参阅开始单个摄像机的实时浏览。
-
右键点击实时浏览图像,在右键菜单中选择 File Source Information 以显示信息类型列表。
-
在列表中选择一种信息类型以显示该信息。
- Fire Source Region——温度高于配置报警阈值的区域。
- Maximum Temperature Region——标记火源区域中温度最高的区域,以绿色标记。
- Fire Source Target——显示目标位置信息。
在实时浏览图像上显示温度信息
查看实时视频时,您可以显示或隐藏监控场景的实时温度信息。
开始之前
- 将设备 VCA 源类型切换为温度测量 + 行为分析。
- 启用设备的温度测量功能并设置温度测量规则,详情请参阅该设备的用户手册。
当您需要在实时浏览图像上显示温度信息时,请执行此任务。
操作步骤
-
进入主视图页面并开始热成像摄像机的实时浏览。
有关开始实时浏览,请参阅开始单个摄像机的实时浏览。
-
将场景调整到配置了温度测量规则的区域。
-
右键点击实时浏览图像,在右键菜单中选择 Show Temperature Information。温度将显示在实时浏览图像上。
-
点击图像查看详细的温度信息。
-
可选:右键点击实时浏览图像并选择 Hide Temperature Information 隐藏温度信息。
手动测温
在热成像摄像机的实时浏览期间,您可以点击实时浏览图像上的任意位置,以显示不同点的温度,从而快速定位火源。
操作步骤
- 测得的温度将在图像上显示 5 秒。
- 只能显示一个点的温度。
- 当多个客户端获取同一摄像机的实时视频时,如果一个客户端添加或删除测量点,其他客户端的实时浏览也会受到影响。当所有用户都停止该摄像机的实时浏览后,测量点将被清除。
-
进入主视图页面并开始热成像摄像机的实时浏览。
有关开始和停止实时浏览,请参阅开始单个摄像机的实时浏览。
-
右键点击实时浏览图像并选择 Show Temperature Information。
-
点击实时浏览图像以显示该位置的温度。所点击点的温度将显示在图像上。
-
可选:右键点击实时浏览图像并在菜单中选择 Hide Temperature Information。
低带宽下的实时浏览
在网络带宽较低的情况下,由于带宽限制,视频流的速度可能会慢得多。为了在较低的流速下为低带宽用户提供正常的画质,客户端提供低带宽模式下的实时浏览。在此之前,您需要先设置流媒体协议并执行其他操作。
有关设置的详情,请参阅 网络带宽较低时,如何获得更好的实时浏览和回放性能?。
更多功能
实时浏览中还支持更多功能,包括辅助屏预览、数字变焦、零通道、双向语音对讲、摄像机状态和同步。
辅助屏预览
在不同的辅助屏上显示实时视频,便于预览多个监控场景。
最多支持 3 个辅助屏。
数字变焦
向右下/左上方向拖动鼠标绘制一个矩形区域,以放大或缩小所绘区域。或在数字变焦模式下使用鼠标滚轮放大或缩小视图。
零通道
对于设备的零通道,按住 Ctrl 键并双击可显示特定通道。再次按住 Ctrl 键并双击可还原。
双向语音对讲
双向语音对讲功能可实现与摄像机的语音通话。您不仅可以获取实时视频,还可以获取来自摄像机的实时音频。如果设备有多个双向语音对讲通道,您可以选择一个通道开始双向语音对讲。
- 双向语音对讲一次只能用于一个摄像机。
- Cloud P2P 设备在双向语音对讲期间不支持选择通道。
摄像机状态
可以检测并显示摄像机状态,例如录像状态、信号状态、连接数等,以供查看。状态信息每 10 秒刷新一次。
同步
同步功能提供一种将设备时钟与运行客户端软件的 PC 同步的方式。
LTS Connect 帮助中心